标签 "yum" 下的文章

第一步:升级g++pdo_sqlsrv的编译安装需要g++在4.4版本以上,centos6默认版本是4.4.7,版本过低了,升级g++两种方法,一个是源码编译,太麻烦,忽略,第二种方法yum升级,简单:wget http://people.centos.org/tru/devtools-2/devtools-2.repo mv devtools-2.repo /etc/yum.repos.d yu

yum install wget -y mv /etc/yum.repos.d/CentOS-Base.repo /etc/yum.repos.d/CentOS-Base.repo_bak wget -O /etc/yum.repos.d/CentOS-Base.repo http://mirrors.aliyun.com/repo/Centos-7.repo mv /etc/yum.repos.

由于规划问题,通过rancher安装的k8s不完美,决定重装。将所有东西都卸载赶紧后docker卸载清除:yum remove docker* -y rm /var/lib/docker -fr rm /var/run/docker -frk8s清除:kubeadmin reset再次通过rancher安装k8s后,一直报错起不来[etcd] Failed to bring up Etcd Pla

python2.6在centos6里面扮演了很重要的角色,很多软件都依托于系统自带的python环境,比如极其重要的yum,很多人在安装Python3的时候会手贱把python2.6给删掉,然后系统很多软件会运行错误。一般来说系统自带的软件被卸载了,用yum重新装一个就完事,但是这里不行,yum也废了。解决办法:通过rpm重新安装所需的包,可以从开源镜像站下载所需的包,也可以直接从系统对应的iso

安装部署K8SMaster和Node都需要操作关闭防火墙systemctl stop firewalld systemctl disable firewalld关闭selinuxsed -i 's/SELINUX=enforcing/SELINUX=disabled/' /etc/selinux/config setenforce 0修改桥接的ipv4流量传递到iptables的链cat <

下载包centos7下面的rpm包,必须安装wget https://downloads.wkhtmltopdf.org/0.12/0.12.5/wkhtmltox-0.12.5-1.centos7.x86_64.rpm --no-check-certificatephp7的扩展包,在php官方手册就可以获取到地址wget https://github.com/krakjoe/wkhtmltox/

下载解压swoolewget https://github.com/swoole/swoole-src/archive/v4.2.13.tar.gz tar -xvf v4.2.13.tar.gz cd swoole-src-4.2.13/编译安装swoole扩展/usr/local/php/bin/phpize ./configure --with-php-config=/usr/local/

yum异常安装包的时候提示:The program package-cleanup is found in the yum-utils package.或:*There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.The